1KZ-TE TIMING ISSUE??

It is currently Tue Jul 22, 2014 6:35 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: 1KZ-TE TIMING ISSUE??
PostPosted: Tue Nov 03, 2009 4:47 pm 
Offline
Hard Yaka

Joined: Sun Oct 11, 2009 9:49 pm
Posts: 212
HI
I HAVE A 93 KZJ78 PRADO WITH THE 1KZ-TE MOTOR.
IT HAS AN INTERMITTANT ISSUE WHERE IT IS DRIVING FINE AND THEN IF I STOP AT LIGHTS AND IT IS IDLING FOR MORE THAN SAY A MINUTE IT STARTS TO KNOCK, ALMOST LIKE A BOTTOM END BLOWEN KNOCK BUT HAVE BEEN TOLD ITS THE INJECTION TIMING, ALSO THE CHECK ENGINE LIGHT COMES ON. BUT THEN IF U TAKE OFF AS SOON AS ITS UNDER LOAD ITS OK.
THERE IS A SENOR ON THE INTAKE SIDE OF THE BLOCK, DOWN THE BOTTOM NEAR THE TRANSMISSION, 2 PIN PLUG, IM GUESSING A KNOCK SENSOR? THIS PULG WAS BROKEN AND IS WAT STARTED THE ISSUE I THINK, I HAVE SINCE REPLACED THIS SENSOR AND THE PLUG THAT GOES ON IT BUT STILL NO CHANGE.

ANY HELP WOULD BE MINT

CHEERS


Top
 Profile  
 
PostPosted: Tue Nov 03, 2009 5:40 pm 
Offline
Hard Yaka
User avatar

 

Joined: Wed Oct 26, 2005 7:00 pm
Posts: 631
Location: Auckland
The timing is computer controlled (can't remember the exact terminology in the wiring diagram).


Top
 Profile  
 
PostPosted: Tue Nov 03, 2009 9:59 pm 
Offline
Hard Yaka

Joined: Thu Dec 11, 2008 7:11 pm
Posts: 263
Location: Feilding
Really should go to garage with scanner to check the fault codes that will be stored as a result of the check engine light going on. It could be many things wrong, eg temp sensor, MAP sensor, TP sensor, even injection pump. Save yourself the headache of replacing stuff that doesnt need to be :) :)


Top
 Profile  
 
PostPosted: Wed Nov 04, 2009 3:53 pm 
Offline
Hard Yaka

Joined: Sun Oct 11, 2009 9:49 pm
Posts: 212
awsome,

cheers for ur help guys i had no idea they could be scanned il go get that done today!!

thanks for ur help!

forum once again saves me $100s.....


Top
 Profile  
 
PostPosted: Thu Nov 05, 2009 1:23 am 
Offline
Hard Yaka

Joined: Fri Aug 18, 2006 7:00 pm
Posts: 1531
Location: West Side
their should be a mark on the block near the front of the fuel pump that the pump lines up to initially set the fuel timing from factory.

does the engine warning light come on and stay on when you start the truck?

has the battery been disconnected since the sensor was damaged.
Disconnecting the battery will clear the fault codes in the ECU.

Pretty sure it is the crank position sensor down the bottom. Was it replaced with a Toyota Genuine Part.


Top
 Profile  
 
PostPosted: Thu Nov 05, 2009 4:11 pm 
Offline
Hard Yaka

Joined: Mon Sep 11, 2006 7:00 pm
Posts: 171
Location: Christchurch
there will also be two wires in the diagnostic plug you can short out and read the faults you're self if you can get you're hands on a manual for the truck it will tell you how to do it and what the codes (flashes of check eng light) correspond to.


Top
 Profile  
 
PostPosted: Thu Nov 05, 2009 10:13 pm 
Offline
Yes Dear
User avatar

Joined: Mon May 29, 2006 7:00 pm
Posts: 8164
Location: Hutt Valley Wellington
I've got a downloaded toyota manual if you need it, it lists the diagnostic functions as well as where all the sensor thingys are..... its only 14mb (can try and email if you arent on dial up etc)


Top
 Profile  
 
PostPosted: Fri Nov 06, 2009 10:42 pm 
Offline
Hard Yaka

Joined: Sun Oct 11, 2009 9:49 pm
Posts: 212
yes i heard bout the flash codes, iv tried getting my hands on a manual but every1 seems to say they dont exsist for these??

engine check light comes on when timing goes out and knocking starts but it is intermittant but kinda getting worse.

jerry, if u could email me the manual that would be awsome?

adam.lange@live.com


Top
 Profile  
 
PostPosted: Sat Nov 07, 2009 12:07 am 
Offline
Hard Yaka

Joined: Fri Jun 30, 2006 7:00 pm
Posts: 1806
Location: Christchurch
You can diagnose the fault codes yourself....its very easy.
Go to the following website & check it out.

http://www.ncttora.com/fsm/1KZ-TE%20Engine%20Manual/hilux/info/manuals/1KZ-TE/index.html

Basically get a small piece of wire & with the key turned off connect terminals TE1 & E1 together.
Then turn on the key...the check engine light will flash & tell the the error codes.


Top
 Profile  
 
PostPosted: Wed Nov 25, 2009 12:07 am 
Offline
Hard Yaka

Joined: Sun Oct 11, 2009 9:49 pm
Posts: 212
i went through the manual understanding it as best i could..
bridged the terminals and took fault codes from ecu..

gave me flash codes..

one flash, two flashes.. code 12 im guessing??

Engine Speed Sensor.. which is the sensor that i thought was knock sensor.
i have since replaced the sensor and there was dodgey loom going to it so replaced the plug and wiring.
started it up. still no change..

disconnected battery for 10min to reset codes??

still no change, noise is now worse, timing seems to be out as soon as i start it up and stays out is not intermittant anymore..

im stumped for ideas....
ECU??


Top
 Profile  
 
PostPosted: Wed Nov 25, 2009 12:32 am 
Offline
Hard Yaka

Joined: Fri Aug 18, 2006 7:00 pm
Posts: 1531
Location: West Side
First thoughts that come to mind.

jumped a tooth on the timing belt?
or injector pump has moved position in relation to the block.
or the wiring fault is further up the loom , have you done a continuity check from the sensor back to the ECU?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Copyright © 2009 OffroadExpress. Site design and build by EzySolutions Ltd, www.ezysolutions.co.nz